The first step is stop completely the cluster.. you can't do that without stop your cluster.
for each package:
# cmhaltpkg <package_name>
Stop the cluster:
# cmhaltcl
Now change the Quorun server:
# vi /etc/cmcluster/cmclconfig.ascii
...
QS_HOST quorum-server
Apply changes:
# cmapplyconf -v -C cmclconfig.ascii
Check the cluster configuration:
# cmcheckconf -v -C cmclconfig.ascii
Star the cluster again:
# cmruncl -v
Now check if the new quorum server is in use.
# cmviewcl -v
MC Serviceguard - Replace Quorum Server
Labels: MC ServiceGuard
What's mean the Serial Number?
See the explanation using the follow serial number as example:
DEH2381234
The first two characters are the country code, in our example Germany (DE)
The third character is the code of the supply site (H ->Herrenberg, Germany)
The next three characters are the date of manufacture, the first digit is for the year then two for the calendar week (238 -> 38th week of 2002)
The last four characters are a sequential ID on that particular week (1234)
Labels: Others
CSE - Speciality in Networking and Security - HP-UX 11i v3
I have completed the last exam to complete the "CSE - Speciality in Networking and Security - HP-UX 11i v3". For those interested and take the exam:
Register for this certification in The Learning Center
Complete prerequisites:
CSA - HP-UX 11iv3
The current CSA exam:
Exam HP0-P20 HP-UX 11iv3 System Administration
Complete requirements:
Core requirement #1
Exam HP0-P21 HP-UX 11iv3 Advanced System Administration
Core requirement #2
Exam HP0-P17 HP-UX 11i v3 Security Administration
Just to remember, now to schedule the certification exam you have to do through "Pearson Vue", you can't do it more through Prometric.
Useful links:
HP - CSE Speciality in Networking and Security - HP-UX 11i v3
Pearson Vue - HP
Labels: Certification
IP forwarding
Check the current state:
# ndd -get /dev/ip ip_forwarding
(0 = disable, 2 = enable)
to enable use the follow command:
# ndd -set /dev/ip ip_forwarding 2
disable:
# ndd -set /dev/ip ip_forwarding 0
If you want leave this configuration permanet you have to add the follow lines in nddconf file
ndd conf file: /etc/rc.config.d/nddconf
lines that need be edited:
TRANSPORT_NAME[X]=ip
NDD_NAME[X]=ip_forwarding
NDD_VALUE[X]=2
Labels: Network
Disable password age for all user
Sure, there's another methods to do that less fun :)
#for i in `awk -F ":" '{print $1}' /etc/passwd`
do
passwd -x -1 $i
done
Installing Powerpath (EMC)
First of all is necessary send the depot to server, download always the last version.
Obs. It's necessary reboot the server.
This command will install the patch:
#swinstall -x autoreboot=true -x mount_all_filesystems=false -s /tmp/EMCPower.HP.4.1.0.tar EMCpower
Where "-s" will receive the full path of the patch.
It's time to configure now:
This command will ask te registration key.
#emcpreg -install
#powermt config
#powermt set policy=so dev=all
#powermt save
You can check your disks:
# powermt display dev=all
Check the powerpath configuration:
# powermt display
Checking the HP-UX installation date
Follow some solution:
Using print_manifest:
# print_manifest | grep -i "The system was created"
Using swlist:
# swlist -l bundle -v HPUXBaseOS | grep mod_date
or
# swlist -a install_date -l product | grep -i os-core
Labels: patch management
What's the patch installation date?
There's different mothods to do that:
1 - Using swlist:
# swlist -l patch -a revision -a title -a state -a install_date
This is the date format:
200903081306.51
YYYYMMDDHHMM.SS
2 - Using "ls":
# ls -dltr /var/adm/sw/products/PH*
Check the creation date on output.
Labels: patch management